Missing lines/Buttons in TheModus screens (Prefab-, Positienumber)
Last modified on: 9 november 2022
Problem:
With activating the TheModus screens for Prefabnumbers or Positienumbers:
- Not all lines are visible or selectable.
- The [ OK ] and [ Cancel ] buttons are not visible (behind lines)
Cause:
The incorrect showning of the screens is most often a result of using a high resolutionmonitor combined with imagescaling.
Solution:
There are several solutions/workarounds available:
- Option 1:
- Close Revit
- Disconnect all but 1 monitor.
- Adjust the image scaling to 100%. (Eventhough adjusting to a 'not standard' scale like 125% might also work.)
- Restart Revit and the screens are displayed correctly.
- Option 2:
- Close Revit
- Browse to the installation folder where you can find the Revit.exe, mostly this is: %ProgramFiles%\Autodesk\Revit 202x\.
- Locate the Revit.exe.
- Open the 'properties' (right mouse click).
- Activate the “Compatibility” tab. (See red circle with 1)
- At the bottom of the tab, activate “Change high DPI settings”. (See red circle with 2)
- Activate the “Override high DPI scaling behavior” option. (See red circle with 3)
- Choose “System” in the dropdownlist (See red circle with 4)
- Click “OK” to change the settings. (See red circle with 5)
- Start Revit.
If the buttons [ OK ] and [ Cancel ] are not visible the can still be used o rnot all lines are shown:
In the specific 'Prefabnumber screen' and the lines 'hanging' over the buttons there are several options:
- In case not all lines are visible and cannot be selected:
Select the last visible line and scroll through the list with the 'arrow down' button. - In case the [ OK ] button is missing one of two methods can be used to finalize the selection:
- Typ or choose the desired prefabnumber, Press the <Tab> button and press <Enter>.
- Typ or choose the desired prefabnumber, Press <Alt> + <O>